Discrepancies with D76 and ID11 dev times

Film Photography & Darkroom discussion

Moderator: Keith Tapscott.

Post Reply
pentaxpete
Posts: 100
Joined: Thu Jan 12, 2006 7:19 am
Location: BRENTWOOD,Essex,(UK)

Discrepancies with D76 and ID11 dev times

Post by pentaxpete »

I have mixed my own ID11 formula for a long time and have found the times quoted for ID11 in ILFORD literature are TOO LONG for most films -- so I looked and found their times for 'D76' which is supposed to be the SAME formula were SHORTER - I have started to use the 'D76 times for ILFORD films. NOW I have a FRESH AGFA APX 400 to process and on checking Massive Dev Chart it gives 16.5 Mins for ID11 1+1 dilution and only 14 mins for D76 !!! So WHY are the TIMES Different when the Formula is supposed to be the SAME?
Got COMPUTERISED and 'slightly Digitised Pentax K10D' but FILM STILL RULES !

Ornello
Posts: 882
Joined: Thu Jan 19, 2006 9:49 am

Re: Discrepancies with D76 and ID11 dev times

Post by Ornello »

That is way too long. Try about half of that time (7 minutes or so).

pentaxpete
Posts: 100
Joined: Thu Jan 12, 2006 7:19 am
Location: BRENTWOOD,Essex,(UK)

Re: Discrepancies with D76 and ID11 dev times

Post by pentaxpete »

I got good negs at 400 ASA with the 14 mins 1+1 dilution and the photos are on Flickr.
Got COMPUTERISED and 'slightly Digitised Pentax K10D' but FILM STILL RULES !

Keith Tapscott.
Posts: 541
Joined: Tue Jan 17, 2006 8:58 am
Location: Plymouth, England.

Re: Discrepancies with D76 and ID11 dev times

Post by Keith Tapscott. »

pentaxpete wrote: Tue Dec 28, 2021 2:14 pm I got good negs at 400 ASA with the 14 mins 1+1 dilution and the photos are on Flickr.
Glad you sorted it Pete.

Post Reply